Your submission was sent successfully! Close

CVE-2018-12558

Published: 20 June 2018

The parse() method in the Email::Address module through 1.909 for Perl is vulnerable to Algorithmic complexity on specially prepared input, leading to Denial of Service. Prepared special input that caused this problem contained 30 form-field characters ("\f").

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
libemail-address-perl
Launchpad, Ubuntu, Debian
Upstream
Released (1.908-1+deb9u1, 1.912-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.912-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.912-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.912-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)