Your submission was sent successfully! Close

CVE-2018-12393

Published: 24 October 2018

A potential vulnerability was found in 32-bit builds where an integer overflow during the conversion of scripts to an internal UTF-16 representation could result in allocating a buffer too small for the conversion. This leads to a possible out-of-bounds write. *Note: 64-bit builds are not vulnerable to this issue.*. This vulnerability affects Firefox < 63, Firefox ESR < 60.3, and Thunderbird < 60.3.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic
Released (63.0+build2-0ubuntu0.18.04.2)
cosmic
Released (63.0+build2-0ubuntu0.18.10.2)
disco
Released (63.0+build1-0ubuntu1)
eoan
Released (63.0+build1-0ubuntu1)
focal
Released (63.0+build1-0ubuntu1)
groovy
Released (63.0+build1-0ubuntu1)
hirsute
Released (63.0+build1-0ubuntu1)
impish
Released (63.0+build1-0ubuntu1)
jammy
Released (63.0+build1-0ubuntu1)
precise Does not exist

trusty Does not exist
(trusty was released [63.0+build2-0ubuntu0.14.04.2])
upstream
Released (63.0)
xenial
Released (63.0+build2-0ubuntu0.16.04.2)
firefox-esr
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs38
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Needs triage

groovy Ignored
(reached end-of-life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs60
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:60.4.0+build2-0ubuntu0.18.04.1)
cosmic
Released (1:60.4.0+build2-0ubuntu0.18.10.1)
disco
Released (1:60.4.0+build2-0ubuntu1)
eoan
Released (1:60.4.0+build2-0ubuntu1)
focal
Released (1:60.4.0+build2-0ubuntu1)
groovy
Released (1:60.4.0+build2-0ubuntu1)
hirsute
Released (1:60.4.0+build2-0ubuntu1)
impish
Released (1:60.4.0+build2-0ubuntu1)
jammy
Released (1:60.4.0+build2-0ubuntu1)
precise Does not exist

trusty Does not exist
(trusty was released [1:60.4.0+build2-0ubuntu0.14.04.1])
upstream
Released (60.3)
xenial
Released (1:60.4.0+build2-0ubuntu0.16.04.1)