CVE-2018-12359

Published: 27 June 2018

A buffer overflow can occur when rendering canvas content while adjusting the height and width of the canvas element dynamically, causing data to be written outside of the currently computed boundaries. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60, Thunderbird < 52.9, Firefox ESR < 60.1, Firefox ESR < 52.9, and Firefox < 61.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (61.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (61.0+build3-0ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (61.0+build3-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [61.0+build3-0ubuntu0.14.04.2])
thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (52.9.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:52.9.1+build3-0ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:52.9.1+build3-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:52.9.1+build3-0ubuntu0.14.04.1])