CVE-2018-12356

Published: 15 June 2018

An issue was discovered in password-store.sh in pass in Simple Password Store 1.7.x before 1.7.2. The signature verification routine parses the output of GnuPG with an incomplete regular expression, which allows remote attackers to spoof file signatures on configuration files and extension scripts. Modifying the configuration file allows the attacker to inject additional encryption keys under their control, thereby disclosing passwords to the attacker. Modifying the extension scripts allows the attacker arbitrary code execution.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
password-store
Launchpad, Ubuntu, Debian
Upstream
Released (1.7.2-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.7.2-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.7.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.7.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)