CVE-2018-12181

Published: 27 March 2019

Stack overflow in corrupted bmp for EDK II may allow unprivileged user to potentially enable denial of service or elevation of privilege via local access.

Priority

Medium

CVSS 3 base score: 6.0

Status

Package Release Status
edk2
Launchpad, Ubuntu, Debian
Upstream
Released (0~20181115.85588389-3)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0~20181115.85588389-3ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0~20181115.85588389-3ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0~20180205.c0d9813c-2ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0~20160408.ffea0a2c-2ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: https://github.com/tianocore/edk2/commit/ffe5f7a6b4e978dffbe1df228963adc914451106
Upstream: https://github.com/tianocore/edk2/commit/89910a39dcfd788057caa5d88b7e76e112d187b5