CVE-2018-12040

Published: 13 June 2018

** DISPUTED ** Reflected Cross-site scripting (XSS) vulnerability in the web profiler in SensioLabs Symfony 3.3.6 allows remote attackers to inject arbitrary web script or HTML via the "file" parameter, aka an _profiler/open?file= URI. NOTE: The vendor states "The XSS ... is in the web profiler, a tool that should never be deployed in production (so, we don't handle those issues as security issues)."

Priority

Negligible

CVSS 3 base score: 6.1

Status

Package Release Status
symfony
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.12+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.4.22+dfsg-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.4.22+dfsg-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist