CVE-2018-1125

Published: 17 May 2018

procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep. This vulnerability is mitigated by FORTIFY, as it involves strncat() to a stack-allocated string. When pgrep is compiled with FORTIFY (as on Red Hat Enterprise Linux and Fedora), the impact is limited to a crash.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
procps
Launchpad, Ubuntu, Debian
Upstream
Released (3.3.15)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:3.3.12-3ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2:3.3.10-4ubuntu2.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:3.3.9-1ubuntu2.3)
Patches:
Upstream: https://gitlab.com/procps-ng/procps/commit/b51ca2a1f8ca779f7632ade6a0a259ed882fa584