CVE-2018-11237

Published: 18 May 2018

An AVX-512-optimized implementation of the mempcpy function in the GNU C Library (aka glibc or libc6) 2.27 and earlier may write data beyond the target buffer, leading to a buffer overflow in __mempcpy_avx512_no_vzeroupper.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

glibc
Launchpad, Ubuntu, Debian
Upstream
Released (2.28)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.28-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.28-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.27-3ubuntu1.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.23-0ubuntu11.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=9aaaab7c6e4176e61c59b0a63c6ba906d875dc0e (master)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=ed983107bbc62245b06b99f02e69acf36a0baa3e (master)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=0cf8a53e5f2ce7f71787537cf206228727afe256 (2.27)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=f51c8367685dc888a02f7304c729ed5277904aff (2.27)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=58ad5f8a646338b2ee3f2136336dcf731e97ab4d (2.26)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=6b4362f2cbb6ef6e265d9f216f3c13d84405a1c0 (2.26)
Upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=b501c7b09eb941dc7ff21f9939c322d2c9c32ec0 (2.24)