CVE-2018-1122

Published: 17 May 2018

procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top. If a user runs top with HOME unset in an attacker-controlled directory, the attacker could achieve privilege escalation by exploiting one of several vulnerabilities in the config_file() function.

Priority

Medium

CVSS 3 base score: 7.0

Status

Package Release Status
procps
Launchpad, Ubuntu, Debian
Upstream
Released (3.3.15)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:3.3.12-3ubuntu1.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2:3.3.10-4ubuntu2.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:3.3.9-1ubuntu2.3)
Patches:
Upstream: https://gitlab.com/procps-ng/procps/commit/b45c4803dd176f4e3f9d3d47421ddec9bbbe66cd