CVE-2018-1100

Published: 11 April 2018

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the utils.c:checkmailpath function. A local attacker could exploit this to execute arbitrary code in the context of another user.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
zsh
Launchpad, Ubuntu, Debian
Upstream
Released (5.5-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (5.4.2-3ubuntu3.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (5.1.1-1ubuntu2.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [5.0.2-3ubuntu6.3])
Patches:
Upstream: https://sourceforge.net/p/zsh/code/ci/31f72205630687c1cef89347863aab355296a27f/