CVE-2018-10913

Published: 04 September 2018

An information disclosure vulnerability was discovered in glusterfs server. An attacker could issue a xattr request via glusterfs FUSE to determine the existence of any file.

From the Ubuntu security team

It was discovered that GlusterFS incorrectly handled FUSE requests. An attacker could use this issue to obtain sensitive information.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
glusterfs
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.1.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.1.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.1.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed