Your submission was sent successfully! Close

CVE-2018-10887

Published: 10 July 2018

A flaw was found in libgit2 before version 0.27.3. It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.

From the Ubuntu security team

It was discovered that libgit2 mishandled specially crafted input. If a victim were tricked into cloning a malicious repository or applying a malicious patch, an attacker could cause libgit2 to leak sensitive information or crash.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
libgit2
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic
Released (0.26.0+dfsg.1-1.1ubuntu0.2)
precise Does not exist

trusty
Released (0.19.0-2ubuntu0.4)
upstream
Released (0.27.4+dfsg.1-0.1)
xenial
Released (0.24.1-2ubuntu0.2)