Your submission was sent successfully! Close

CVE-2018-10859

Published: 16 July 2018

git-annex is vulnerable to an Information Exposure when decrypting files. A malicious server for a special remote could trick git-annex into decrypting a file that was encrypted to the user's gpg key. This attack could be used to expose encrypted data that was never stored in git-annex

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
git-annex
Launchpad, Ubuntu, Debian
Upstream
Released (6.20180626-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(7.20190129-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(7.20190129-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(7.20190129-3)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)