Your submission was sent successfully! Close

CVE-2018-1059

Published: 24 April 2018

The DPDK vhost-user interface does not check to verify that all the requested guest physical range is mapped and contiguous when performing Guest Physical Addresses to Host Virtual Addresses translations. This may lead to a malicious guest exposing vhost-user backend process memory. All versions before 18.02.1 are vulnerable.

Priority

Low

CVSS 3 base score: 6.1

Status

Package Release Status
dpdk
Launchpad, Ubuntu, Debian
Upstream
Released (17.11.2-1)
Ubuntu 21.10 (Impish Indri)
Released (17.11.2-1)
Ubuntu 21.04 (Hirsute Hippo)
Released (17.11.2-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (17.11.2-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (17.11.2-1ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist