CVE-2018-1000807

Published: 08 October 2018

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
pyopenssl
Launchpad, Ubuntu, Debian
Upstream
Released (17.5.0)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(17.5.0-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.15.1-2ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: https://github.com/pyca/pyopenssl/pull/723
Upstream: https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509

Notes

AuthorNote
mdeslaur
requires python-cryptography 2.1.4 which adds X509_up_ref, see
https://github.com/pyca/cryptography/pull/4028

References