CVE-2018-1000301

Published: 16 May 2018

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream
Released (7.60.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (7.58.0-2ubuntu3.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (7.47.0-1ubuntu2.8)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (7.35.0-1ubuntu2.16)