CVE-2018-1000127

Published: 13 March 2018

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
memcached
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.0-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.5.6-0ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.4.25-2ubuntu1.4)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.4.14-0ubuntu9.3])
Patches:
Upstream: https://github.com/memcached/memcached/commit/a8c4a82787b8b6c256d61bd5c42fb7f92d1bae00