CVE-2018-1000097

Published: 12 March 2018

Sharutils sharutils (unshar command) version 4.15.2 contains a Buffer Overflow vulnerability in Affected component on the file unshar.c at line 75, function looks_like_c_code. Failure to perform checking of the buffer containing input line. that can result in Could lead to code execution. This attack appear to be exploitable via Victim have to run unshar command on a specially crafted file..

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
sharutils
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:4.15.2-3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1:4.15.2-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:4.14-1ubuntu1.1)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Other: http://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00005.html