Your submission was sent successfully! Close

CVE-2017-9765

Published: 20 July 2017

Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
gsoap
Launchpad, Ubuntu, Debian
Upstream
Released (2.8.48-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.8.60-2build1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.8.60-2build1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.8.60-2build1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.8.60-2build1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Distro: https://bugzilla.suse.com/attachment.cgi?id=733005&action=diff