Your submission was sent successfully! Close

CVE-2017-9112

Published: 21 May 2017

In OpenEXR 2.2.0, an invalid read of size 1 in the getBits function in ImfHuf.cpp could cause the application to crash.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
openexr
Launchpad, Ubuntu, Debian
Upstream
Released (2.2.0-11.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.2.0-11.1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.2.0-10ubuntu2.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/openexr/openexr/commit/f09f5f26c1924c4f7e183428ca79c9881afaf53c (2.3)
Upstream: https://github.com/openexr/openexr/commit/49db4a4192482eec9c27669f75db144cf5434804 (2.2)