CVE-2017-8845

Published: 08 May 2017

The lzo1x_decompress function in lzo1x_d.ch in LZO 2.08, as used in lrzip 0.631, allows remote attackers to cause a denial of service (invalid memory read and application crash) via a crafted archive.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
lrzip
Launchpad, Ubuntu, Debian
Upstream
Released (0.631+git180517-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.631+git200516-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.631+git180528-1build1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/ckolivas/lrzip/commit/89d7b33e6a6450eed326b40084b547d42bad333f