CVE-2017-8787

Published: 05 May 2017

The PoDoFo::PdfXRefStreamParserObject::ReadXRefStreamEntry function in base/PdfXRefStreamParserObject.cpp:224 in PoDoFo 0.9.5 allows remote attackers to cause a denial of service (heap-based buffer over-read) or possibly have unspecified other impact via a crafted PDF file.

Priority

Low

CVSS 3 base score: 8.8

Status

Package Release Status
libpodofo
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.9.5-9)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.9.5-9)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.5-9)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.9.5-9)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)