CVE-2017-7787

Published: 10 August 2017

Same-origin policy protections can be bypassed on pages with embedded iframes during page reloads, allowing the iframes to access content on the top level page, leading to information disclosure. This vulnerability affects Thunderbird < 52.3, Firefox ESR < 52.3, and Firefox < 55.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (55.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (55.0.2+build1-0ubuntu4)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (55.0.1+build2-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [55.0.1+build2-0ubuntu0.14.04.2])
mozjs38
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (52.3.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:52.4.0+build1-0ubuntu2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:52.3.0+build1-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:52.3.0+build1-0ubuntu0.14.04.1])