CVE-2017-7758

Published: 14 June 2017

An out-of-bounds read vulnerability with the Opus encoder when the number of channels in an audio stream changes while the encoder is in use. This vulnerability affects Firefox < 54, Firefox ESR < 52.2, and Thunderbird < 52.2.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (54.0)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (54.0+build3-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [54.0+build3-0ubuntu0.14.04.1])
thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (52.2.0)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1:52.2.1+build1-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:52.2.1+build1-0ubuntu0.14.04.1])