Your submission was sent successfully! Close

CVE-2017-7654

Published: 05 June 2018

In Eclipse Mosquitto 1.4.15 and earlier, a Memory Leak vulnerability was found within the Mosquitto Broker. Unauthenticated clients can send crafted CONNECT packets which could cause a denial of service in the Mosquitto Broker.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
mosquitto
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.4-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.5.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.5.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.5.4-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.4.15-2ubuntu0.18.04.3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.4.8-1ubuntu0.16.04.7)
Ubuntu 14.04 ESM (Trusty Tahr) Needed