Your submission was sent successfully! Close

CVE-2017-7616

Published: 10 April 2017

Incorrect error handling in the set_mempolicy and mbind compat syscalls in mm/mempolicy.c in the Linux kernel through 4.10.9 allows local users to obtain sensitive information from uninitialized stack data by triggering failure of a certain bitmap operation.

From the Ubuntu security team

It was discovered that an information leak existed in the set_mempolicy and mbind compat syscalls in the Linux kernel. A local attacker could use this to expose sensitive information (kernel memory).

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by cf01fb9985e8deb25ccf0ea54d916b8871ae0e62
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc6)