CVE-2017-7585

Published: 07 April 2017

In libsndfile before 1.0.28, an error in the "flac_buffer_copy()" function (flac.c) can be exploited to cause a stack-based buffer overflow via a specially crafted FLAC file.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
libsndfile
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.27-2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.25-10ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.25-7ubuntu2.2)
Patches:
Distro: https://sources.debian.net/data/main/libs/libsndfile/1.0.27-2/debian/patches/fix_bufferoverflows.patch
Upstream: https://github.com/erikd/libsndfile/commit/60b234301adf258786d8b90be5c1d437fc8799e0