CVE-2017-7550

Published: 21 November 2017

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

Priority

Negligible

CVSS 3 base score: 9.8

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.2.0+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.5.1+dfsg-1)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)