Your submission was sent successfully! Close

CVE-2017-7521

Published: 21 June 2017

OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service due to memory exhaustion caused by memory leaks and double-free issue in extract_x509_extension().

Priority

Medium

CVSS 3 base score: 5.9

Status

Package Release Status
openvpn
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.3, 2.3.17)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.3.10-1ubuntu2.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.3.2-7ubuntu3.2)
Patches:
Upstream: https://github.com/OpenVPN/openvpn/commit/cb4e35ece4 (master)
Upstream: https://github.com/OpenVPN/openvpn/commit/0400840671 (2.4)
Upstream: https://github.com/OpenVPN/openvpn/commit/1dde0cd6e5 (2.3)