CVE-2017-7472

Published: 11 May 2017

The KEYS subsystem in the Linux kernel before 4.10.13 allows local users to cause a denial of service (memory consumption) via a series of KEY_REQKEY_DEFL_THREAD_KEYRING keyctl_set_reqkey_keyring calls.

From the Ubuntu security team

Eric Biggers discovered a memory leak in the keyring implementation in the Linux kernel. A local attacker could use this to cause a denial of service (memory consumption).

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
Patches:
Introduced by d84f4f992cbd76e8f39c488cf0c5d123843923b1
Fixed by c9f838d104fed6f2f61d68164712e3204bf5271b
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.11~rc8)