CVE-2017-7300

Published: 29 March 2017

The Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, has an aout_link_add_symbols function in bfd/aoutx.h that is vulnerable to a heap-based buffer over-read (off-by-one) because of an incomplete check for invalid string offsets while loading symbols, leading to a GNU linker (ld) program crash.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
binutils
Launchpad, Ubuntu, Debian
Upstream
Released (2.27.51.20161212-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.28-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.28-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.28-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.26.1-1ubuntu1~16.04.8+esm1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=531336e3a0b79ed60cfc36ad2d6579b6a71175da