CVE-2017-6967

Published: 17 March 2017

xrdp 0.9.1 calls the PAM function auth_start_session() in an incorrect location, leading to PAM session modules not being properly initialized, with a potential consequence of incorrect configurations or elevation of privileges, aka a pam_limits.so bypass.

From the Ubuntu security team

It was discovered that PAM incorrectly initialized session modules. This could potentially bypass enforcement of limits.

Priority

Medium

CVSS 3 base score: 7.3

Status

Package Release Status
xrdp
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.1-9)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.9.5-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.5-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.9.5-2)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed