CVE-2017-6960

Published: 17 March 2017

An issue was discovered in apng2gif 1.7. There is an integer overflow resulting in a heap-based buffer over-read, related to the load_apng function and the imagesize variable.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
apng2gif
Launchpad, Ubuntu, Debian
Upstream
Released (1.5-1+deb7u1, 1.8-0.1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.8-0.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.8-0.1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.5-3+deb8u1build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)