Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-6843

Published: 15 March 2017

Heap-based buffer overflow in the PoDoFo::PdfVariant::DelayedLoad function in PdfVariant.h in PoDoFo 0.9.4 allows remote attackers to have unspecified impact via a crafted file.

From the Ubuntu Security Team

Agostino Sarubbo discovered that PoDoFo mishandled certain crafted PDF files, resulting in a heap-based buffer overflow. If PoDoFo were to open a malicious PDF, an attacker could cause PoDoFo to crash or possibly execute arbitrary code.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
libpodofo
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(0.9.5-9)
cosmic Not vulnerable
(0.9.5-9)
disco Not vulnerable
(0.9.5-9)
eoan Not vulnerable
(0.9.5-9)
focal Not vulnerable
(0.9.5-9)
groovy Not vulnerable
(0.9.5-9)
hirsute Not vulnerable
(0.9.5-9)
impish Not vulnerable
(0.9.5-9)
jammy Not vulnerable
(0.9.5-9)
kinetic Not vulnerable
(0.9.5-9)
lunar Not vulnerable
(0.9.5-9)
mantic Not vulnerable
(0.9.5-9)
precise Ignored
(end of life)
trusty
Released (0.9.0-1.2ubuntu0.1~esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (0.9.4-6, 0.9.0-1.1+deb7u2)
xenial Needed

yakkety Ignored
(end of life)
zesty Ignored
(end of life)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H