Your submission was sent successfully! Close

CVE-2017-6437

Published: 15 March 2017

The base64encode function in base64.c in libimobiledevice libplist 1.12 allows local users to cause a denial of service (out-of-bounds read) via a crafted plist file.

Priority

Negligible

CVSS 3 base score: 5.0

Status

Package Release Status
libplist
Launchpad, Ubuntu, Debian
Upstream
Released (1.12+git+1+e37ca00-0.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.12+git+1+e37ca00-0.3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [code not present])
Patches:
Upstream: https://github.com/libimobiledevice/libplist/commit/dccd9290745345896e3a4a73154576a599fd8b7b

Notes

AuthorNote
ratliff
vanilla 1.12 does not suffer this issue, it was most likely introduced
during the post-1.12 refactoring of parse_bin_node

References

Bugs