Your submission was sent successfully! Close

CVE-2017-6435

Published: 15 March 2017

The parse_string_node function in bplist.c in libimobiledevice libplist 1.12 allows local users to cause a denial of service (memory corruption) via a crafted plist file.

Priority

Low

CVSS 3 base score: 5.0

Status

Package Release Status
libplist
Launchpad, Ubuntu, Debian
Upstream
Released (1.12+git+1+e37ca00-0.2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.12+git+1+e37ca00-0.2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.12+git+1+e37ca00-0.2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.12+git+1+e37ca00-0.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.12+git+1+e37ca00-0.2)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/libimobiledevice/libplist/commit/fbd8494d5e4e46bf2e90cb6116903e404374fb56