Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-6319

Published: 2 March 2017

The dex_parse_debug_item function in libr/bin/p/bin_dex.c in radare2 1.2.1 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a crafted DEX file.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
radare2
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(2.3.0+dfsg-2)
cosmic Not vulnerable
(2.3.0+dfsg-2)
disco Not vulnerable
(2.3.0+dfsg-2)
precise Ignored
(end of life)
trusty Does not exist
(trusty was needed)
upstream
Released (1.1.0+dfsg-3)
xenial Not vulnerable
(code not present)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)
Patches:
upstream: https://github.com/radare/radare2/commit/ad55822430a03fe075221b543efb434567e9e431

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H