Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!Close

CVE-2017-6280

Published: 6 March 2018

NVIDIA driver contains a possible out-of-bounds read vulnerability due to a leak which may lead to information disclosure. This issue is rated as moderate. Android: A-63851980.

From the Ubuntu Security Team

sbeattie> drivers/gpu/drm/nouveau/nvkm/core/ioctl.c::nvkm_ioctl() sbeattie> possibly fixed in bf81df9be28657eea4aca8c6ab4ed3e69f8a051c

Notes

AuthorNote
smb
cking found that the ioctl interface was added much later than the
driver (8ec2a6ec6e229d67b19737f9b603eef478fa955d -> 3.17)

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.13.0-16.19)
upstream
Released (4.3~rc1)
artful Not vulnerable
(4.10.0-19.21)
trusty Not vulnerable

xenial Not vulnerable
(4.3.0-1.10)
Patches:
Introduced by

8ec2a6ec6e229d67b19737f9b603eef478fa955d

Fixed by bf81df9be28657eea4aca8c6ab4ed3e69f8a051c
linux-armadaxp
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-linaro-omap
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Does not exist

linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
upstream
Released (4.3~rc1)
artful Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
xenial Not vulnerable
(4.4.0-1001.10)
linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
upstream
Released (4.3~rc1)
artful Does not exist

trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
xenial Not vulnerable
(4.11.0-1009.9)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Ignored
(was needs-triage ESM criteria)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Not vulnerable
(4.10.0-1004.4)
linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Ignored
(end of standard support, was needs-triage)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Ignored
(end of life, was needs-triage)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable

upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic
Released (4.18.0-8.9~18.04.1)
upstream
Released (4.3~rc1)
artful Does not exist

trusty Does not exist

xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Not vulnerable
(4.15.0-1002.2)
trusty Does not exist

upstream
Released (4.3~rc1)
xenial Not vulnerable
(4.4.0-1004.9)
linux-lts-saucy
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist

upstream
Released (4.3~rc1)
xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist

upstream
Released (4.3~rc1)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist
(trusty was ignored [end of standard support])
upstream
Released (4.3~rc1)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Ignored
(end of life, was needs-triage)
upstream
Released (4.3~rc1)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist
(trusty was ignored [end of standard support])
upstream
Released (4.3~rc1)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Not vulnerable
(4.4.0-13.29~14.04.1)
upstream
Released (4.3~rc1)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.3~rc1)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.3~rc1)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.3~rc1)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Not vulnerable
(4.15.0-1002.3)
trusty Does not exist

upstream
Released (4.3~rc1)
xenial Not vulnerable
(4.13.0-1008.9)
linux-qcm-msm
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist

upstream
Released (4.3~rc1)
xenial Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
artful Not vulnerable
(4.10.0-1004.6)
bionic Not vulnerable
(4.13.0-1005.5)
trusty Does not exist

upstream
Released (4.3~rc1)
xenial Not vulnerable
(4.3.0-1006.6)
linux-snapdragon
Launchpad, Ubuntu, Debian
artful Not vulnerable
(4.4.0-1050.54)
bionic Not vulnerable

trusty Does not exist

upstream
Released (4.3~rc1)
xenial Not vulnerable
(4.4.0-1012.12)
linux-ti-omap4
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

trusty Does not exist

upstream
Released (4.3~rc1)
xenial Does not exist

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact None
Availability impact None
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N