CVE-2017-6010

Published: 16 February 2017

An issue was discovered in icoutils 0.31.1. A buffer overflow was observed in the "extract_icons" function in the "extract.c" source file. This issue can be triggered by processing a corrupted ico file and will result in an icotool crash.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
icoutils
Launchpad, Ubuntu, Debian
Upstream
Released (0.31.2-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.31.2-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.31.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.31.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.31.2-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.31.0-3ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.31.0-2+deb8u3build0.14.04.1])
Patches:
Upstream: http://git.savannah.gnu.org/cgit/icoutils.git/commit/?id=bf97b99109607d4367a4e57df9a37cbcac02e220
Upstream: http://git.savannah.gnu.org/cgit/icoutils.git/commit/?id=45a0207225df4cd4b82f41eee636e21f11a7db74