Your submission was sent successfully! Close

CVE-2017-5953

Published: 10 February 2017

vim before patch 8.0.0322 does not properly validate values for tree length when handling a spell file, which may result in an integer overflow at a memory allocation site and a resultant buffer overflow.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
neovim
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(0.2.2-3)
cosmic Not vulnerable
(0.2.2-3)
disco Not vulnerable
(0.2.2-3)
eoan Not vulnerable
(0.2.2-3)
precise Does not exist

trusty Does not exist

upstream
Released (0.1.7-4)
xenial Does not exist

vim
Launchpad, Ubuntu, Debian
artful Not vulnerable
(2:8.0.0197-4ubuntu5)
bionic Not vulnerable
(2:8.0.1144-1ubuntu1)
cosmic Not vulnerable
(2:8.0.1144-1ubuntu1)
disco Not vulnerable
(2:8.0.1144-1ubuntu1)
eoan Not vulnerable
(2:8.0.1144-1ubuntu1)
precise
Released (2:7.3.429-2ubuntu2.3)
trusty
Released (2:7.4.052-1ubuntu3.1+esm1)
upstream
Released (2:8.0.0197-2)
xenial
Released (2:7.4.1689-3ubuntu1.3)
yakkety Ignored
(reached end-of-life)
zesty Ignored
(reached end-of-life)