CVE-2017-5846

Published: 09 February 2017

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
gst-plugins-ugly0.10
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.10.19-2+deb7u1ubuntu0.1])
gst-plugins-ugly1.0
Launchpad, Ubuntu, Debian
Upstream
Released (1.10.3-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.10.3-1ubuntu1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.10.3-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.10.3-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.10.3-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://cgit.freedesktop.org/gstreamer/gst-plugins-ugly/commit/?id=dec880031d16f1ee4919a36f49298419246cf6a8