Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-5843

Published: 9 February 2017

Multiple use-after-free vulnerabilities in the (1) gst_mini_object_unref, (2) gst_tag_list_unref, and (3) gst_mxf_demux_update_essence_tracks functions in GStreamer before 1.10.3 allow remote attackers to cause a denial of service (crash) via vectors involving stream tags, as demonstrated by 02785736.mxf.

From the Ubuntu Security Team

Hanno Böck discovered that GStreamer Bad Plug-ins incorrectly handled vectors involving stream tags. A remote attacker could exploit this with a crafted MXF file to cause GStreamer to crash, resulting in a denial of service.

Priority

Low

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
gst-plugins-bad0.10
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

precise Ignored
(end of life)
trusty
Released (0.10.23-7.2ubuntu1.3+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream Needed

xenial Does not exist

yakkety Does not exist

zesty Does not exist

gst-plugins-bad1.0
Launchpad, Ubuntu, Debian
artful Not vulnerable
(1.10.3-1ubuntu1)
bionic Not vulnerable
(1.10.3-1ubuntu1)
cosmic Not vulnerable
(1.10.3-1ubuntu1)
disco Not vulnerable
(1.10.3-1ubuntu1)
eoan Not vulnerable
(1.10.3-1ubuntu1)
focal Not vulnerable
(1.10.3-1ubuntu1)
groovy Not vulnerable
(1.10.3-1ubuntu1)
hirsute Not vulnerable
(1.10.3-1ubuntu1)
impish Not vulnerable
(1.10.3-1ubuntu1)
jammy Not vulnerable
(1.10.3-1ubuntu1)
kinetic Not vulnerable
(1.10.3-1ubuntu1)
lunar Not vulnerable
(1.10.3-1ubuntu1)
mantic Not vulnerable
(1.10.3-1ubuntu1)
noble Not vulnerable
(1.10.3-1ubuntu1)
precise Does not exist

trusty Needed

upstream
Released (1.10.3-1)
xenial Needed

yakkety Ignored
(end of life)
zesty Not vulnerable
(1.10.3-1ubuntu1)
Patches:
upstream: https://github.com/GStreamer/gst-plugins-bad/commit/08723e6

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H