Your submission was sent successfully! Close

CVE-2017-5576

Published: 06 February 2017

Integer overflow in the vc4_get_bcl function in drivers/gpu/drm/vc4/vc4_gem.c in the VideoCore DRM driver in the Linux kernel before 4.9.7 allows local users to cause a denial of service or possibly have unspecified other impact via a crafted size value in a VC4_SUBMIT_CL ioctl call.

From the Ubuntu security team

Murray McAllister discovered that an integer overflow existed in the VideoCore DRM driver of the Linux kernel. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
Patches:
Introduced by d5b1a78a772f1e31a94f8babfa964152ec5e9aa5
Fixed by 0f2ff82e11c86c05d051cae32b58226392d33bbf
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.10~rc6)

Notes

AuthorNote
jdstrand
android kernels (flo, goldfish, grouper, maguro, mako and manta) are
not supported on the Ubuntu Touch 14.10 and earlier preview kernels
linux-lts-saucy no longer receives official support
linux-lts-quantal no longer receives official support
tyhicks
See lkml.org link for the proposed fix. As of 2017-01-25, the fix has
not been committed upstream.

References