Your submission was sent successfully! Close

CVE-2017-2816

Published: 13 September 2017

An exploitable buffer overflow vulnerability exists in the tag parsing functionality of LibOFX 0.9.11. A specially crafted OFX file can cause a write out of bounds resulting in a buffer overflow on the stack. An attacker can construct a malicious OFX file to trigger this vulnerability.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libofx
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Not vulnerable
(1:0.9.12-1)
cosmic Not vulnerable
(1:0.9.12-1)
disco Not vulnerable
(1:0.9.12-1)
precise Does not exist

trusty Does not exist
(trusty was needed)
upstream
Released (1:0.9.11-4, 1:0.9.10-1+deb9u1, 1:0.9.4-2.1+deb7u1)
xenial
Released (1:0.9.10-1+deb8u1build0.16.04.1)
zesty Ignored
(reached end-of-life)