Your submission was sent successfully! Close

CVE-2017-2801

Published: 24 May 2017

A programming error exists in a way Randombit Botan cryptographic library version 2.0.1 implements x500 string comparisons which could lead to certificate verification issues and abuse. A specially crafted X509 certificate would need to be delivered to the client or server application in order to trigger this vulnerability.

From the Ubuntu security team

It was discovered that Botan did not properly manage x509 DN strings comparisons when provided with a specially crafted X509 certificate. An attacker could possibly use this issue to cause out of bound reads, resulting in information leakage, denial of service, or potentially incorrect certificate validation results.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
botan1.10
Launchpad, Ubuntu, Debian
Upstream
Released (1.10.16-1)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.10.16-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)