Your submission was sent successfully! Close

CVE-2017-20005

Published: 06 June 2021

NGINX before 1.13.6 has a buffer overflow for years that exceed four digits, as demonstrated by a file with a modification date in 1969 that causes an integer overflow (or a false modification date far in the future), when encountered by the autoindex module.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
nginx
Launchpad, Ubuntu, Debian
Upstream
Released (1.13.6-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.14.0-0ubuntu1.7)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.10.3-0ubuntu0.16.04.5+esm2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.4.6-1ubuntu3.9+esm3)