Your submission was sent successfully! Close

CVE-2017-18184

Published: 13 February 2018

An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
qpdf
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.0-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus)
Released (8.0.2-3~16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [8.0.2-3~14.04.1])
Patches:
Upstream: https://github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317

Notes

AuthorNote
leosilva
couldn't reproduce in trusty or xenial. Also code in these
two releases are quite different from patch one.

References

Bugs