Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-17915

Published: 27 December 2017

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a heap-based buffer over-read in ReadMNGImage in coders/png.c, related to accessing one byte before testing whether a limit has been reached.

From the Ubuntu Security Team

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
groovy Not vulnerable
(1.3.27-3)
hirsute Not vulnerable
(1.3.27-3)
artful Ignored
(end of life)
bionic Not vulnerable
(1.3.27-3)
cosmic Not vulnerable
(1.3.27-3)
disco Not vulnerable
(1.3.27-3)
eoan Not vulnerable
(1.3.27-3)
focal Not vulnerable
(1.3.27-3)
impish Not vulnerable
(1.3.27-3)
jammy Not vulnerable
(1.3.27-3)
upstream
Released (1.3.27-3)
xenial
Released (1.3.23-1ubuntu0.6)
zesty Ignored
(end of life)
trusty
Released (1.3.18-1ubuntu3.1+esm6)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H