CVE-2017-17857

Published: 27 December 2017

The check_stack_boundary function in kernel/bpf/verifier.c in the Linux kernel through 4.14.8 allows local users to cause a denial of service (memory corruption) or possibly have unspecified other impact by leveraging mishandling of invalid variable stack read operations.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
Patches:
Introduced by f1174f77b50c94eecaa658fdc56fa69b421de4b8
Fixed by ea25f914dc164c8d56b36147ecc86bc65f83c469
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.15~rc5)