Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-17670

Published: 15 December 2017

In VideoLAN VLC media player through 2.2.8, there is a type conversion vulnerability in modules/demux/mp4/libmp4.c in the MP4 demux module leading to a invalid free, because the type of a box may be changed between a read operation and a free operation.

Notes

AuthorNote
mikesalvatore
According to the openwall thread, "the VLC project probably
won't backport a fix to 2.2.x." I'm deferring this CVE.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
vlc
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(3.0.3-1-1ubuntu1)
cosmic Not vulnerable
(3.0.4-2build1)
disco Not vulnerable
(3.0.4-2build1)
eoan Not vulnerable
(3.0.4-2build1)
focal Not vulnerable
(3.0.4-2build1)
groovy Not vulnerable
(3.0.4-2build1)
hirsute Not vulnerable
(3.0.4-2build1)
impish Not vulnerable
(3.0.4-2build1)
jammy Not vulnerable
(3.0.4-2build1)
kinetic Not vulnerable
(3.0.4-2build1)
lunar Not vulnerable
(3.0.4-2build1)
mantic Not vulnerable
(3.0.4-2build1)
noble Not vulnerable
(3.0.4-2build1)
trusty Does not exist

upstream
Released (3.0.2-0+deb9u1)
xenial Deferred
(2019-04-23)
zesty Ignored
(end of life)

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H